Minor Performance Printing Issues

Incident Report for Loftware Cloud Clinical Trials

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 17:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2025 - 17:12 UTC

Investigating

Some reports have come in in relation to performance issues which are currently being investigated
Posted Nov 17, 2025 - 17:10 UTC
This incident affected: Loftware Cloud CT - VC Netherlands (CT Service).